포스팅 내용

국내외 보안동향

Libssh CVE-2018-10933 스캐너, 익스플로잇 공개 돼 – 지금 업데이트 하세요

Libssh CVE-2018-10933 Scanners & Exploits Released - Apply Updates Now


지난 주, Libssh에 존재하는 너무나도 쉽게 악용이 가능한 인증 우회 취약점이 공개 되었습니다. 이후, 공격자들이 원격으로 이 취약점을 악용해 취약한 기기에서 명령어를 실행할 수 있도록 하는 툴 및 스크립트 다수가 공개 되고 있습니다.


이 취약점은 CVE-2018-1093로 등록 되었으며, libssh가 SSH2_MSG_USERAUTH_REQUEST를 기다릴 때 SSH2_MSG_USERAUTH_SUCCESS를 보내기만 하면 악용이 가능해 매우 쉽습니다. 이로써 라이브러리는 해커가 정상적으로 인증 되었다고 판단하고 입장을 허용합니다.


이 취약점은 libssh 버전 0.7.6와 0.8.4에서 수정 되었으며, 연구원들은 이 취약점을 간단히 악용해 원격으로 취약한 버전에서 명령을 실행시킬 수 있도록 하는 스캐너 및 스크립트를 공개했습니다.


아래는 이 취약점과 관련 된 권고문들입니다.


업체들의 Libssh CVE-2018-10933 관련 권고


Arch Linux

Arch Linux는 사용자들에게 아래의 명령어를 통해 libssh 버전 0.8.4-1로 업그레이드 할 것을 권고했습니다.


pacman -Syu "libssh>=0.8.4-1"


Cisco

Cisco는 보안 권고를 통해 이 취약점에 영향을 받는 기기를 조사 중이라 밝혔습니다.


Debian

Debian은 이 취약점을 해결하는 libssh용 업데이트 패키지를 발표했습니다.


Dell

Dell 지원 포럼에서 Dell EMC Enterprise Support Services의 담당자는 자사 제품이 libssh2를 사용하고 있으며 이 취약점에 영향을 받지 않는다고 밝혔습니다.


F5 Networks

F5 Networks는 권고를 발행해 SSH Proxy 컴포넌트의 BIG-IP(AFM) 제품 버전 12.1.0 - 12.1.3, 13.0.0 - 13.1.1, 및 14.0.0이 취약하다고 밝혔습니다. 아직까지 패치는 발행 되지 않았습니다.


Red Hat

Red Hat은 이 취약점이 Red Hat Enterprise Linux 7 Extras에 포함 된 libssh에만 영향을 미친다고 밝혔습니다. 이 외 다른 패키지는 이 취약점에 영향을 받지 않습니다.


SUSE

SUSE는 권고를 발행해 이 취약점이 SUSE Linux Enterprise Desktop 12 SP 3, SUSE Linux Enterprise Module for Basesystem 15, SUSE Linux Enterprise Software Development Kit 12 SP3, SUSE Linux Enterprise Workstation Extension 12 SP3, openSUSE Leap 15.0, openSUSE Leap 42.3에 영향을 미친다고 밝혔습니다.

SUSE는 이 취약점을 해결할 수 있는 업데이트의 목록을 공개했습니다.


Ubuntu

Ubuntu는 권고를 발행해 Ubuntu 18.04 LTS, Ubuntu 16.04 LTS, Ubuntu 14.04 LTS가 이 취약점에 영향을 받는다고 밝혔습니다. 취약점 해결을 위한 업데이트의 목록도 함께 공개했습니다.



연구원들, 동작하는 익스플로잇 및 스캐너 공개


CVE-2018-10933이 공개 된 후, 연구원들은 libssh의 취약점을 악용하는 툴을 만드는 작업에 착수했습니다. 이 툴은 재빨리 공개 되었으며, 누구나 간단히 취약한 기기를 스캔하고 원격으로 명령어를 실행할 수 있도록 합니다.


Leap Security는 취약한 기기를 스캔하는데 사용할 수 있는 파이썬 스크립트를 공개했습니다.


[Leap security의 CVE-2018-10933 스캐너]

<이미지 출처: https://www.kitploit.com/2018/10/libssh-scanner-script-to-identify-hosts.html>


기기를 발견하면, 사용자가 취약점을 악용해 명령어를 실행시키는 것을 도와줄 수 많은 툴들이 있습니다.


툴들이 풍부하게 제공되었기 때문에, 이 취약점에 영향을 받는 기기를 사용 중이라면 보안 업데이트를 확인 후 즉시 설치해야 할 것입니다. 





출처 :

https://www.bleepingcomputer.com/news/security/libssh-cve-2018-10933-scanners-and-exploits-released-apply-updates-now/



티스토리 방명록 작성
name password homepage